Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RÉSOLU] problèmes avec page d'accueil et nombre d'articles
  • Bonjour,
    j'ai opté pour le thème autofocus, je le trouve très
    beau ! Néanmoins, j'ai 2 problèmes majeurs, peut être les avez vous
    aussi rencontrés.

    Quand on choisit une photo "couverture" pour un
    article, elle est visible en page d'accueil. Mais elles apparaissent
    souvent tronquées et complétées par un rectangle gris rayé, ce qui casse
    toute l'esthétique. J'ai essayé différents formats de photos, je ne
    trouve pas la solution.

    Autre problème, dans le menu
    "configurer", on choisit le nombre d'articles qui apparaissent par page
    (maxi 25). Du coup, quand on clique sur un tag, seuls les 25 derniers
    articles au mieux apparaissent, pas de flèche pour accéder aux
    précédents...

    Avez vous des solution ou des idées pour régler tout ça ? Merci d'avance !
    Mon blog, si ça peut aider http://camdup.over-blog.com/
    Merci !
    Camille
  • Bonjour, 
    Il faudrait que tu ajoutes un code dans la partie css de ton html. 
    Ajoute entre les lignes 335 et 336 : 
                .m-main .box img{
                    width:100%;
                }
  • Bonjour Brigades,
    merci pour ta réponse !
    Je viens d'essayer, le code agit bien sur la taille des images, mais ça fusionne plusieurs articles entre eux... C'est pas encore ça. Néanmoins, grâce à ton conseil je comprends mieux d'où vient le problème !
    Peut être modifier quelque chose entre les lignes 320 et 332 pour que ces rectangles gris deviennent blancs ? plus neutres...
                .m-main .post{
                    background: url(http://assets.over-blog-kiwi.com/themes/31/images/pattern-1.png);
                    float: left;
                    height: 360px;
                    margin-bottom: 5px;
                    position: relative;
                }
                .m-main .box{
                    height: 360px;
                    left: 0;
                    overflow: hidden;
                    position: absolute;
                    top: 0;


    Merci beaucoup ! J'ai de l'espoir ! :)
  • C'est curieux. Je n'ai pas ce problème pour les posts précédant la mise à jour Overblog, quand les photos étaient encore intégrées au bloc texte...
  • Oui, tu peux remplacer l'url de l'image par une couleur : 
                .m-main .post{
                    background-color:#FFFFFF; background-image:none;
                    float: left;
                    height: 360px;
                    margin-bottom: 5px;
                    position: relative;
                }
  • Cool ! pour cette histoire de fond gris c'est réglé ! C'est déjà bien mieux :
    http://camdup.over-blog.com/

    Et est-ce que quelqu'un a une piste pour mon deuxième problème ? Je n'ai que 12 articles qui apparaissent par tag, pas moyen d'accéder aux plus anciens... Peut-on ajouter une flèche "articles précédents" ?
    Merci d'avance pour vos idées !
    Camille

  • Je relance car j'ai le même souci : j'ai intégré la modification de couleur pour que le cadre gris soit blanc, et donc moins visible. Mais ça reste assez peu esthétique (espace plus grand entre 2 photos, ça fait bizarre, d'autant plus que la zone de titre grisée garde la taille initiale, plus large que la photo visible ...).
    Il n'y a pas moyen de forcer la photo a prendre tout l'espace ?

    http://mediatheque.mirecourt.over-blog.com/
  • up pour ceux qui auraient une idée ...