Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RÉSOLU] HTML actives sur un blog et inactives sur un autre (même thème Noodle, même code de base)
  • Bonjour Medhi,
    nous avons échangé avant les vacances sur le blog http://www.grhl.fr que je réalisait pour une asso et pour lequel tu m'as aidé à corriger certains défauts d'affichage ou à modifier certains fonctions. J'étais connectée avec leur adresse mail.
    Aujourd'hui, je construis un nouveau blog et comme je suis très satisfaite de noodle et des modifs, j'ai tout simplement copié-collé ces modifs (avant /Style) pour les appliquer à mon nouveau blog. Il y a même tes propres commentaires que j'ai laissé pour me souvenirs de ce que cela implique...
    Ci-dessous le code mais il ne reproduit pas les couleurs. En fait tous les énoncés des sections concernées sont en rouge (vois directement dans le code du site concerné : http://www.chroniquesterriennes.com) comme si il ne faisait pas le lien avec les fonctions. Et effectivement, rien ne s'applique sur le premier article test posté qui regroupe presque tous les cas d'affichage : espaces trop importants entre les section, police des légendes, césure des mots etc...)
    Je ne m'attendais pas à ça vu que le noodle de base n'a pas été modifié autrement que pas des ajouts et non des suppressions de code.

    c'est un copié-collé direct : il ne manque aucune balise.

    Donc... je suis perplexe ☺, bien sûr
    As-tu une idée de ce qu'il se passe ?


    /* suppression de l'url apparent dans la section lien*/
                 
                  .ob-url  {
        display:none; 
                  }

                  /* Masque du widget Vous aimerez aussi dans la colonne de gauche */
                  .Sidebar-widget[data-order="17"] { 
    display: none;
                                    }
                  /* j'ai ajouté une marge de 1 px qui fait descendre la section image */
                 
                  .ob-section-images, .ob-section-images img, .ob-section-map .ob-map, .ob-section-map .ob-desc {
        margin-bottom: 5px;
                               }
                 
                  /* ici cela remonte la section texte */
                 
                  .ob-section-html, .ob-section-html iframe, .ob-section-html>* {
        max-width: 100%;
        margin-top: 5px;
                                    }
                 
                  /* ici j'ai mis une marge négative pour la section "lien" qui lui permet de remonter */
                 
                  .ob-section-link .ob-ctn { margin-top: -15px;
                      }
                 
                  /* légende image section image Margin = espacement entre légend et image*/
                 
                  .ob-section .ob-desc {
        font-size: .9em;
        margin: -5px auto 0;
        text-align: center;
        font-style: italic;
        color: #262626;
                                    }
                 
                  /* légende image section texte */
                 
                  figure>figcaption {
        font-style: italic;
        display: block;
        font-size: 0.9em;
        margin: 6px auto: 0;
         color: #262626;
                                }
                 
                  /* retour à la ligne des légendes
                 
                        .ob-section-html, .ob-section-html iframe, .ob-section-html>* {
        max-width: 100%;
        margin-top: 0px;
                                    }

                 figure>figcaption {
        width: 80%;
        line-height: 20px;
            text-align:center;
              }*/
                 
                  /* empêcher la césure de mots */
                 
                  .ob-section {
                    -webkit-hyphens: none;
                    -moz-hyphens: none;
                    -ms-hyphens: none;
                    hyphens: none;
                    word-wrap: break-word; }
  • Bonjour,

    je vois:

     /* retour à la ligne des légendes
                 
                        .ob-section-html, .ob-section-html iframe, .ob-section-html>* {
        max-width: 100%;
        margin-top: 0px;
                                    }

                 figure>figcaption {
        width: 80%;
        line-height: 20px;
            text-align:center;
              }*/

    __________

    */   devrais etre en haut aprés :   /* retour à la ligne des légendes


  • Bonjour,

    je n'ai pas encore testé car je suis a l’étranger jusqu’à lundi

    je vois ça a mon retour


  • Merci Mehdi,
    Sur cette partie du code c'est normal. Je l'ai masqué en mettant les balises commentaires volontairement pour pouvoir y revenir si besoin. C'est comme ça sur l'autre blog. En fait ce qui m'alerte c'est la police rouge qui semblent dire qu'il ne rattache pas le style aux sections concernées alors qu'elles existent. On voit ça lundi.
    Bon week-end.

  • Bonjour Medhi, je ne sais pas si tu as eu le temps de jeter un oeil.

    De mon côté, j'ai comparé quasi ligne par ligne les deux codes noodle (sur grhl et chroniques terriennes) : aucune différence.
    Je n'arrive donc à expliquer pourquoi ces lignes de codes ajoutées s'appliquent sur un site et par sur l'autre.

    De plus, il y avait 2 lignes de codes que j'avais ajoutées pour mettre automatiquement les titres des articles en majuscule à la fois sur la page d'accueil et à l'affichage des articles :


    .PostPreview-title
    .Post-title


    j'y ai inséré pour chacun → text-transform: uppercase;

    Je viens de le faire ce matin. Pareil ça fonctionne très bien sur grhl et ça n'est pas pris en compte sur le nouveau blog.


    grrrr
  • Désolée pour la lecture, mais j'ajoute aussi ceci:

    dans ton code proposé, cette fois, j'ai remarqué ces balises que je ne m'explique pas en terme de synthaxe. Mais visiblement ça n'impacte pas le GRHL. Sur le nouveau blog je les ai supprimé, ça ne change absolument rien avec ou sans. Cette fois j'ai vraiment fini. ☺

    /* ici cela remonte la section texte */
                 
                  .ob-section-html, .ob-section-html iframe, .ob-section-html>* {
        max-width: 100%;
        margin-top: 5px;
                                    }

  • Bonjour,

    peut essayer de copier bloc par bloc puis enregistrer pour voir celui qui pose probleme


  • C'est fait, un par un. Rien ! Tous les appels vers .ob-section, figure, .ob-url etc. restent en rouge.

    Par contre, le code pour avoir les titres en majuscule fonctionne. ça on oublie.

  • bonsoir,

    peut tu me mettre ici le lien vers ton nouveau blog en création que j'aille voir son code



  • Bonjour,

    ce n'est pas le thème noodle il me semble ? j'ai un doute.


    Date de 2007