Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RÉSOLU] Déplacement de la sidebar
  • Bien le bonjour
    Surprise, ce matin la sidebar se retrouve sous les articles. Comment faire pour la remettre à sa place c'est à dire à droite? svp.
    Dans le CSS j'ai juste ajouté les lignes 72 à 82 avant la balise </style>.
    Décidément on ne s'ennuie pas avec la migration :)
    Merci :)
  • Bonjour,

    Puis-je te demander en premier de compléter ta "carte de visite" en suivant les instructions du premier com (et plus spécialement la première partie ^^ ) de cette discussion  :
    http://fr.forum.over-blog-kiwi.com/discussion/105/important-a-lire-avant-de-poster-un-message-lien-blog-avatar-pseudo-forum/p1 

    Merci ;)
  • Bonjour :)
    Je ne sais pas si ma carte est bien complétée n'étant pas un adepte des forums. Voici l'adresse de mon blog:
    Mes problèmes:
    1/ Quand on est sur la page d’accueil la sidebar est placée en dessous des articles.
    2/ Si je sélectionne les tags: mine, nature et carrières la sidebar est bien à droite mais légèrement décalée
    Si je sélectionne le tag tourisme l'affichage est bon.
    Pas simple tout ça 
    :( :)
  • Bonjour Baguenaudes, 
    Dans ton css V2 caché, tu as ceci (j'ai éliminé tout ce qui est parasite pour simplifier) :
    #global {width: 1150px;}
    #cl_1_0 {width: 829px;}
    #cl_1_1 {width: 320px;}
    Tu as donc un blog de 1150 pixels dans lequel tu veux faire loger deux colonnes de respectivement 829 et 320 pixels. 
    Déjà, sans compter les marges tu te rends compte que ça peux fonctionner, mais il y a des espaces entre les colonnes qui font que ça ne loge pas. 

    Ajout ces trois lignes dans ton code html juste avant la petite ligne </style> puis fais des tests en augmentant le vert ou en diminuant le rose et/ou le bleu. 
  • Merci pour votre réponse mais je ne crois pas que le problème vient de là car la largeur du module article est le même quand  je l'affiche  au travers des tags et là la sidebar est  bien positionnée (à peu près).
    Je vais quand même chercher où se trouve la largeur des articles dans le CSS mais ce n'est pas gagné 
    :(
  • Merci aussi brigades. Nos courriers se sont croisés.
    Heu c'est quoi et où le cssV2 caché ?
    J'ai bien ajouté les 3 lignes . J'ai mis 1200 600 et 300 pour voir mais les modifs ne sont  pas actives.
    #global {width: 1200px;}
    #cl_1_0 {width: 600px;}
    #cl_1_1 {width: 300px;}
    /*-Fin-personnalisation--*/
        </style>
  • C'est parce que l'ancien css est plus bas, donc c'est lui qui prends toujours la main. 
    Mais regarde, tu as plus bas ceci : 
    <!-- SEO -->

    <style type="text/css">







    </style>
    C'est ici que tu va mettre ta personnalisation. 
  • Pfff c'est ben compliqué tout ça ! Merci de t'y pencher !
    J'ai donc inséré à partir de la ligne 336.
    Les modifs ont l'air d'être actives mais la sidebar reste en bas :(
  • Alors c'est plus compliqué car le menu et la colonne des modules sont inclus dans la colonne des articles, il faut les en sortir. 
    Je reviendrais avec une solution. 
    Tu n'auras qu'à faire un copié collé. 
  • Bonjour,

    Le problème est ailleurs.
    Le bloc div class="fond" n'est pas fermé dans le premier article "Vestiges Carriers Mis à jour"  X_X

    Le blog s'affiche d'ailleurs bien avec d'autres pages http://baguenaudes.over-blog.com/tag/Mines/ 

    ;)
  • J'ai pensé à ça mais je ne trouve pas le DIV manquant...
  • C'est dans le dernier article.
    On voit d'ailleurs que le bloc après l'article (avec repost, "published by"...) est décalé par rapport aux autres articles. 
  • Bon alors essai de réparation : éditer ton article, passer le dernier bloc texte en mode html et y ajouter un </DIV> en dernier lieu, tout valider, vérifier. 
  • OK merci à tous c’était bien un DIV manquant.Ah que l'informatique est perverse. Bravo à vous d'avoir trouvé.

    :)>-
    Reste un petit détail si j'ose, concernant l'affichage de la sidebare quand on sélectionne par tag. Elle est légèrement décalée vers le bas sauf pour le tag tourisme. Quand je dis que l'informatique est perverse!
    Bon ce n'est pas bien grave
    Merci encore
  • C'est à cause de la navigation entre les pages qui n'apparaît pas sur certaines pages 
    On peut garder l'alignement entre blocs articles et bloc modules en ajoutant par exemple côté CSS :

    .before_articles .pagination {min-height: 15px;}
  • Trop fort ! Merci beaucoup pour votre patience et compétence.