Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RÉSOLU] Google font : insertion dans le code non opérationnelle
  • Bonjour,

    Je souhaite modifier ma police de caractère en faisant appel à Google font en suivant les indications de Medhi que je recopie ci-après :


    une solution existe en utilisant Google font il est possible d’insérer toutes sortes de police visible par tous

    https://www.google.com/fonts

    google founi le code JavaScript à insérer dans le code du thème qui fera appel a la police désiré sur Google font;..ainsi tous les visiteurs peuvent lire la ou les fontes choisi car il ne l'ont pas forcement d'office sur leur pc

    il y a un tuto ici




    Je suis scrupuleusement le tuto (merci à l'auteure) mais la deuxième action, consistant à coller le bout de code 'font-family...' dans la partie HTML...

                /* Global properties */
                body {background: #595e03; border: 0; font: 14px font-family: 'Mitr', sans-serif;
                ; color: {{ Custom("custom_page_font_color")|default('#a9b400') }}; line-height: 20px;}
                a {color: #a9b400; outline: none; text-decoration: none;}

    ...ne fonctionne pas. 

    Je note que le code original n'a pas la même structure ( pas d'appel à font-family: et Arial contenu entre deux " " alors que Mitr, simple ' ')

    /* Global properties */
                body {background: #595e03; border: 0; font: 14px "Arial", Helvetica, sans-serif; 
    color: {{ Custom("custom_page_font_color")|default('#a9b400') }}; line-height: 20px;}
                a {color: #a9b400; outline: none; text-decoration: none;}

    Je suis novice en la matière, je n'avance quand faisant des déductions, désolé si cela est très basique mais je viens de très loin...

    merci de votre aide
  • Bonjour,

    je vois 2  ; (point virgule ) ici

    font-family: 'Mitr', sans-serif;
                ; color

    vérifie le tuto pour voir si pas d'autres erreur


  • Peut tu compléter l'adresse de ton blog sur le profil forum 

    dans le rectangle blanc, après avoir cliqué sur ce lien

    Si tu arrive pas, voir la marche à suivre sur ce fil

    Actuellement,on ne peut pas visualiser ton blog 


  • Bonjour et merci bien Mehdi, en effet, une bête erreur de  ; (point virgule )

    C'est corrigé et ça fonctionne bien.

    je cherche à régler encore quelques problèmes :

     - un souci à présent sur la bannière (image 1) : je voudrais que mon image passe derrière la fonction recherche (image 2) or, j'obtiens un résultat avec la fonction 'recherche' en dessous la bannière (image 3)

    image

  • Bonjour,

    tu dois chercher la dernière balise </style> de ton css, celle avant </HEAD> <BODY>

    on va ajouter  ces lignes de code avant </style>:

    #search {
        margin-top: -95px;
        padding: 10px 20px 0 0;
    }

    h1#logo {
        height: 150px;
        width: 900px;
    }

    ________________

    explications:

    j'ai élargi le fond de ta bannière a 900 px de large au lieu de 600 px actuellement

    Pour remonter le bouton recherche, j'ai pas trouvé d'autre solution que de lui demander une marge haute négative    margin-top: -95px;

    en simulation cela fonctionne





  • sur le thème photofolio la balise </style>  se trouve vers la ligne 521

    image
  • wow! excellent travail! merci beaucoup, c'est le rendu que je voulais, bravo!
  • wow! excellent travail! merci beaucoup, c'est le rendu que je voulais, bravo!