Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RÉSOLU] traducteur google ne marche plus en article
  • Bonjour,


    Je travaille sur la reconfiguration de mon blog suite au changement de plateforme.
    j'avais pour habitude de rajouter ce "traducteur" à la fin de chaque article et page :

    <div id="google_translate_element">&nbsp;</div>
    <script type="text/javascript"> // <![CDATA[ function googleTranslateElementInit() { new google.translate.TranslateElement({ pageLanguage: 'fr' }, 'google_translate_element'); } // ]]> </script><script src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit" type="text/javascript"> </script>


    Probleme, ca ne marche que sur les pages et plus dans les articles , comment faire?
    MErci
  • pas d'aide?

    Serait il possible de mettre le code cité ci dessus quelque part dans le html/ccs de mon thème pour ne pas l'avoir à le repetter dans chaque article.

    Surtout que le fait de travailler sur mon blog, ralenti mon PC au point qu'il m'a fallut une heure pour changer la date de seulement 10articles afin de commencer à remettre de l'ordre dans le classement.

    Pour résumer, j'aimerai sauver l'essentiel pendant que la vitesse revienne en mode administration...
    Si, si, j'ai confiance...
    Merci
  • Bonsoir

    va en configuration et met le sur un module texte libre disponible

    pour ton pc ,peut etre tester avec un autre navigateur et/ou faire les mise ajour de flashplayer et/ou javascript
  • Disons que ca marchait très bien avant la migration....

    Je vais tenter le coup du module.... merci, bonne idée...
    esperons que ca marche
  • Bon, j'ai tenté de placer ca sur un module : <div id="google_translate_element">&nbsp;</div>
    <script type="text/javascript"> // <![CDATA[ function googleTranslateElementInit() { new google.translate.TranslateElement({ pageLanguage: 'fr' }, 'google_translate_element'); } // ]]> </script><script src="http://translate.google.com/translate_a/element.js?cb=googleTranslateElementInit" type="text/javascript"> </script>

    Ca ne marche pas.
    Idem  dans un article
    PAr contre, ca fontionne dans les pages.... Je ne comprends pas...

  • Bonjour,
    dans le script, je vois 
    pageLanguage: 'fr' 
    sais pas si ça peut venir de là. 
  • Merci Kinou,

    Je viens de résoudre le problème en me servant de l'idée de Medhi et en trouvant un code qui fonctionne contrairement à celui qu'il y avait dans mes articles. Tu étais sur la bonne voie.
    Peut être que la migration l'a modifié puisque ça marchait avant. En tout cas, çà marchait dans mes pages mais pas les articles après migration
    Problème résolu en me servant donc d'un module texte libre et en supprimant le code de toutes mes pages et articles (enfin, j'essaie, c'est long avec le "lag") Si je laissais le code dans mes articles ou pages, le module n’apparaissait plus mais l'article en faisait apparaitre deux... (pas facile à comprendre ce que je dis....).
    Merci pour l'aide apportée
    Voici  ce qui a résolu mon problème :
    Pour rajouter un module de traduction Google :

    Vous allez sur translate.google.com/translate_tools
    vous complétez avec l'adresse de votre blog, le design du widget voulu ...et obtenez 2 codes (
    ne copiez pas ceux-là, ils correspondent à mon blog).

    Le premier de ce type
     <meta
    name="google-translate-customization"
    content="fe2ca0ac80e5e879-7f7199a4b4e4b03c-g81e9679f2636b393-23"></meta>

    devra être placé tout en haut du HTML/CSS après <!-- options -->

    Le second de ce type
    <div id="google_translate_element"></div><script type="text/javascript">
    function googleTranslateElementInit() {
     
    new google.translate.TranslateElement({pageLanguage: 'fr', layout:
    google.translate.TranslateElement.InlineLayout.SIMPLE},
    'google_translate_element');
    }
    </script><script
    type="text/javascript"
    src="//translate.google.com/translate_a/element.js?cb=googleTranslateElementInit"></script>


    devra être placé dans la partie HTML qui correspond à l'endroit où vous voulez voir apparaître sur le blog le menu des langues.

  • Bonjour

    je vois, en effet,  ton traducteur à droite...nickel.......  ainsi tu aura bien un module de traduction visible sur l'ensemble du blog sans le rajouter à la main à chaque fois. ;)
  • Si tu m'avais dit que tu voulais un traducteur google, je t'aurais envoyé sur ce fil de la FAQ :D
  • Je confirme, la migration a changé le code du traducteur dans mes articles, je ne trouve pas les memes à fur et à mesure que je l'efface.
    Bon, j'en ai pour quelques heures mais l'important est que je sais ou je vais maintenant.
  • Et oui pour la FAQ... mea culpa...
    Je dois avouer que j'ai un peu du mal à retrouver mes petits sur le forum. Je manque de pratique.

    Oui pour Medhi, c'est mieux comme ca. C'était une tres bonne idée...