Bienvenue sur le forum d'entraide d'OverBlog.
Nous vous conseillons de chercher une réponse sur notre base de connaissances avant de poster une demande sur le forum.
[RESOLU] Affichage en mode résumé - pas de photos
  • Bonjour !

    Je souhaiterais passer en mode résumé car beaucoup de mes articles sont longs. Seulement, seul un résumé de texte apparaît alors qu'en général, une image devrait être affichée.

    J'ai beaucoup cherché sur le web et mes images sont bien hébergées sur OB, elles sont suffisamment grandes et pour chaque article, il y a bien une photo de couverture sélectionnée...

    Je ne comprend pas pourquoi ça ne s'affiche pas... même sur l'aperçu dans l'éditeur de thème les images n'apparaissent pas...

  • Bonsoir,

    normal, le thème girl gift que tu utilise n'affiche pas d'images en mode résumé
  • Il n'y a pas la possibilité de le rajouter ? Je vais essayer de voir sur les autres thèmes si je trouve...
  • J'ai remplacé : 

    <div class='post-body entry-content'>
    {% if isSingle or Custom('display_mode') == 'All' %}
    {{ Post.Body }}
        <p class="readmore">
    <a href="{{ Post.PermaLink }}">{{ Lang.Get('See comments') }}
    </a>
    </p>
    {% else %}
    <p>{{ Post.Snippet }}
    </p>
    <p class="readmore">
    <a href="{{ Post.PermaLink }}">{{ Lang.Get('Read more') }}
    </a>
    </p>
    {% endif %}
    </div>

    par :

    {% if isIndex and Custom('display_mode') == 'Summary' %}
    <div class="post-cover">
    <a href="{{ Post.PermaLink }}" title="{{ Post.Snippet }}">
    {% if Post.Cover is not empty %}
    <img src="{{ Post.Cover|crop }}" alt="" title="" width="auto" height="332" />
    {% elseif Custom('custom_thumbnail') is not empty %}
    <img src="{{ Custom('custom_thumbnail')|crop }}" alt="" title="" width="auto" height="332" />
    {% endif %}
    </a>
    </div>
    {% endif %}
    <div class="post-body">
    {% if isSingle or Custom('display_mode') == 'All' %}
    {{ Post.Body }}
    {% else %}
    <p>{{ Post.Snippet }}</p>
    {% endif %}
    {% if not isSingle %}
    <p class="readmore">
    <a href="{{ Post.PermaLink }}">
    {% if Custom('display_mode') == 'All' %}
    {{ Lang.Get('See comments') }}
    {% else %}
    {{ Lang.Get('Read more') }}
    {% endif %}
    </a>
    </p>
    {% endif %}
    </div>

    Par contre, je n'arrive pas à centrer les images.... j'ai mis align="center" dans la balise <img> mais ça n'a aucun effet
    j'ai essayé avec align="middle" align="float: center" mais rien...

  • bonjour,

    Le style des images doit être réglé avec le CSS. Chercher </style> et ajouter la ligne pour le style des images dans les résumés :


    {% endif %}
    .post-cover img{} /*ajout ligne pour image résumé*/
    </style>
    </head>
    <body>

    (vers ligne 1560)

    parce que l'image est dans un bloc div avec pour classe post-cover

    Pour centrer : 

    .post-cover img{display:block;margin:auto;}

    Eviter les débordements :

    .post-cover img{max-width:100%;}


  • C'est parfait !

    Merci infiniment !
  • Bonjour,
    J'ai suivi les indications donnés, ça a bien marché dans l'accueil du blog, cependant, dans les catégories, les articles s'affichent toujours sans l'image...Pouvez vous m'aidez svp ? merci d'avance. 
  • Bonjour,

    c'est normal, il n'y pas d'images dans le module "catégorie" à gauche.

    Ce qui est un peu normal car si je prend ta catégorie" plat" qui contient 22 articles, quelle photo de quel article choisir.....
  • Merci Mehdi pour ta réponse. 
    mais quand j'ouvre la catégorie plat par exemple, il y a plusieurs articles qui apparaissent mais dans les résumés de chaque articles, il n'y a pas de photo...
  • Bonjour

    je viens de faire des essais avec un de mes blog test en utilisant ton thème et en effet girl gift ne reprends pas d'image sur les résumés en catégorie meme si on en "épingle" une à la rédaction d'un article

    avec un "repost" il y a bien une petite vignette par contre

    je ne vois pas comment faire pour le moment pour changer ça car il faut passer par le langage "twig" et iv oam n'est plus sur ob......donc pas facile à trouver les bonnes lignes à ajouter (if.......else....)

  • j'ai "reposté" un article mais pas de petite vignette dans les catégories...

    pour ce qui est du langage "twig" : c'est du chinois pour moi loool

    merci quand même pour tes réponses; c'est sympa!